به روز رسانی افزونه وردپرس Yoast باعث ایجاد خطاهای مرگبار می شود

افزونه Yoast WordPress یک عذرخواهی برای به روز رسانی ناموفق منتشر کرد که منجر به مشکلات جدی وب سایت برای ناشران شد
افزونه Yoast WordPress SEO یک به روز رسانی منتشر کرد اما به زودی مشخص شد که مشکلی وحشتناک برای برخی از کاربران پیش آمده است. به نظر می رسد که این مشکل باعث خطاهای مرگبار شده است. قربانیانی که تأثیر منفی به‌روزرسانی Yoast داشتند، مجبور شدند به نسخه قبلی Yoast برگردند.
به گفته یکی از کاربران، نصب وردپرس آنها طبق ایمیلی که برای آنها ارسال شده است، آنها را از "خطای مرگبار" آگاه کرده است.
Yoast مسئولانه و سریع مشکل را برطرف کرد و بابت اتفاقی که افتاده عذرخواهی کرد.
Yoast 18.4 قصد داشت ویژگی جدیدی را معرفی کند که محتوا و مُهرهای داده‌های ساختاری را با هدف حفاظت از حق چاپ با استفاده از فناوری بلاک چین معرفی می‌کند.
ویژگی جدید به سرویسی به نام WordProof متصل شد که مُهرهای زمانی قابل تأییدی را ارائه می‌کند که به بازدیدکنندگان سایت نشان می‌دهد که محتوا نوشته شده و به‌روزرسانی شده است.
سرویس WordProof یک گواهی بلاک چین برای تأیید یک مهر زمانی و یک ابزار نقض حق چاپ ارائه می دهد.
هدف ذکر شده برای WordProof تقویت اعتماد با یک وب سایت با ارائه اثبات و شفافیت است.
طبق WordProof:
اینترنت مشکلات ریشه‌ای دارد که هر روز افزایش می‌یابد: بی‌اعتمادی، سرقت ادبی، و اخبار جعلی. WordProof می خواهد استاندارد جدیدی برای اینترنت قابل اعتمادتر و قابل اعتمادتر با کمک فناوری بلاک چین ایجاد کند.
متاسفانه ادغام این ویژگی باعث شد تا Yoast به اشکال جدی برای کاربران دچار مشکل شود.
در زمان نگارش این مقاله، برخی از مشتریان Yoast نشان دادند که این خطا بر نسخه‌های 18.4 و 18.4.1 Yoast تأثیر گذاشته است.
طبق گفته Yoast، افزونه رایگان Yoast نسخه 18.4.1 و Yoast SEO Premium 18.2.1 هر دو نسخه های پایداری هستند که دیگر ویژگی WordProof جدید را در خود ندارند.
WordProof شرکتی است که در صفحه درباره ما لیستی از شرکای زن و شوهر از بنیانگذاران Yoast آورده است.
به روز رسانی محکوم به فنا افزونه سئوی Yoast WordPress باعث ایجاد اختلالات گسترده برای برخی از مشتریان شد.
مشکلات معمولی که گزارش شد:
یکی از کاربران گزارش داد که هسته وردپرس یک پیام هشدار در مورد افزونه Yoast ایمیل کرده است:
“از زمان وردپرس 5.2 یک ویژگی داخلی وجود دارد که تشخیص می‌دهد که یک پلاگین یا تم باعث ایجاد خطای مرگبار در سایت شما می‌شود و با این ایمیل خودکار به شما اطلاع می‌دهد.
در این مورد، وردپرس با یکی از افزونه های شما، Yoast SEO خطایی گرفت.
کاربر اسناد مربوط به خطاهای بد افزونه SEO SEO را به اشتراک گذاشته است:
به روز رسانی پلاگین بد Yoast یکی دیگر از مشتریان Yoast برای شرح مشکلات خود به صفحه پشتیبانی عمومی Yoast پست کرد:
«پس از به‌روزرسانی از افزونه yoast seo 18.3 -> 18.4 در صفحه وضعیت سلامت سایت، می‌توانم برخی از خطاها را ببینم:
…REST API با خطای عملکرد مواجه شد
… درخواست REST API به دلیل یک خطا ناموفق بود."
یک کاربر دیگر افزونه Yoast برای اطلاع رسانی به Yoast از خطای مشابه نوشت:
خطای بحرانی پس از به‌روزرسانی وردپرس 5.9.2 و Yoast 18.4.1
… درخواست REST API به دلیل یک خطا ناموفق بود."
به نظر می رسد مشکل مربوط به مشکل REST API یک شکایت نسبتاً رایج باشد، زیرا قربانیان به روز رسانی Yoast دیگری نیز آن را گزارش کرده اند.
یکی دیگر از کاربران افزونه Yoast نوشت که Yoast وب سایت خود را شکست :
"سایت من ناگهان شروع به نمایش صفحات خالی، صفحات خطا، صفحات با فرمت محدود در یک مرورگر دسکتاپ کرد (یعنی مانند گذشته تمام صفحه مرورگر را اشغال نمی کند) و غیره. همچنین من ناگهان نتوانستم صفحه اصلی خود را ویرایش کنم…"
درخواست کمک دیگر:
"من نمی توانم پست یا صفحه را ویرایش کنم. خطا می اندازد. وقتی افزونه رو غیر فعال کردم تا مشکل ناپدید شود
… خطا: ویرایشگر با یک خطای غیرمنتظره مواجه شده است.
این افزونه برای بسیاری از کاربرانی که شروع به ارسال پست به صفحه پشتیبانی افزونه Yoast در WordPress.org کردند، خطاهای مهلکی ایجاد کرد.
Yoast در مورد به روز رسانی مشکل دار بیانیه عذرخواهی صادر کرد:
با وجود آزمایش های گسترده، متاسفانه برخی از کاربران با Yoast SEO 18.4 مشکلاتی را تجربه کردند.
از آنجایی که آنها به سرعت با تیم پشتیبانی 24 ساعته ما تماس گرفتند، ما توانستیم به سرعت عمل کنیم و این نسخه را لغو کنیم.
…. برای هر گونه ناراحتی که ممکن است برای شما پیش آمده باشد بسیار متاسفیم."
Yoast به مشتریان اطمینان داد که آخرین نسخه‌ها (Yoast SEO 18.4.1 و Yoast SEO Premium 18.2.1) پایدار هستند و در تاریخ بعد دوباره از ادغام WordProof بازدید خواهند کرد.
Yoast در حال حاضر با PHP 8+ سازگار نیست. حداقل یکی از افرادی که خطا را گزارش می‌کنند، متوجه شده است که از PHP 8.0 استفاده می‌کنند.
در یک سوال پشتیبانی نامربوط، شخصی پرسید که آیا Yoast با آخرین نسخه PHP، نسخه 8.x سازگار است یا خیر.
نماینده پشتیبانی Yoast نوشت:
"متاسفانه، ما هنوز این افزونه را به طور کامل با PHP نسخه 8 آزمایش نکرده ایم. کل جامعه وردپرس هنوز روی آن کار می کنند."
بنابراین ممکن است که برای آن کاربر خاص، PHP 8.0 ممکن است مشکلات مرکب باشد.
Yoast به روز رسانی به آخرین نسخه های پایدار افزونه خود را توصیه می کند. ممکن است عاقلانه باشد که بررسی کنید وب سایت شما PHP 8.+ را اجرا نمی کند و در صورت امکان، ابتدا سایت را مرحله بندی کنید تا بررسی کنید که آیا درست کار می کند یا خیر.
Yoast SEO 18.4.1 و Premium 18.2.1 هم اکنون در دسترس هستند
خبرنامه روزانه ما را از لورن بیکر بنیانگذار SEJ در مورد آخرین اخبار در صنعت دریافت کنید!
راجر مونتی یک بازاریاب جستجو با بیش از 20 سال تجربه است. ارائه ممیزی سایت، مشاوره تلفنی و محتوا و … [بیو کامل را بخوانید]
برای دریافت آخرین اخبار صنعت در خبرنامه روزانه ما مشترک شوید.
برای دریافت آخرین اخبار صنعت در خبرنامه روزانه ما مشترک شوید.

source
سئو سایت

About mohtavaclick

Check Also

به روز رسانی لینکدین شامل پیشرفت هایی در نتایج جستجو می شود

به‌روزرسانی‌های لینکدین شامل بهبودهایی در کشف محتوا، زیرنویس‌ها برای رویدادهای هم‌زمان و امکان اشتراک‌گذاری نظرات …

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.

قالب وردپرس وردپرس متخصص وردپرس متخصص ووکامرس افزونه وردپرس کابین وردپرس